星期六, 八月 19, 2006

AIGLX on ATI Radeon Moblility 7500 does work!!




It is so amazing that after days of tweaking, I finally get my Compaq Presario 2821(2800 series) with built-in ATI Radeon Mobility 7500 3d-accelerator cooperate with AIGLX on Ubuntu Dapper 6.06LTS!

I was following the AIGLX/compiz howto on the ubuntu forum, however, I always got the error 'GLX_EXT_texture_from_pixmap is missing' when I invoking 'compiz-start', and it went no further.

Finally I re-add the commented options of video adapter, and switch from 'ati' driver to 'radeon':
  • "RenderAccel" "true"
  • "AGPMode" "4"
  • "AGPFastWrite" "true"
  • "EnablePageFlip" "True"
And then it just worked!
One more thing, it is not 'firegl' but the DRI driver! Unlike the failure of XGL on Korora 2 Live CD, which require the OpenGL support of proprietary drivers, aiglx works with free drivers!

Now it's time to add 'compiz-start' into gnome start-up sessions!
=======================================

评:AIGLX不错,特别是对glx缺乏驱动支持的7500这样的老显卡。
一直以来,ATI Radeon 7500在Linux上就处于一个尴尬地位,ATI官方的fgl驱动最低支持8500,没有我的事,而free的dri驱动对于xgl这样的高难度动作一直中听不中看:就一个摆设!现在俺不用担心别人用Vista时俺会木有面子了!

据说这几天有很多7500用户成功的打开了osx86(Hackintosh)上的QE支持,小小的xb了一把,看来俺的希望还是挺大的,毕竟QE还是(理论上)支持7500的。

现在的感觉就是:
gnome有点像Mac OS X!

2 条评论:

He 说...

大哥,能给我发个ati7500的osx驱动吗,谢谢!
我的邮箱:billyhyz@126.com

Zhangchn 说...

我也没有啊。上次碰osx还是半年多前了。